Ticket #189 (closed defect: wontfix)

Opened 9 years ago

Last modified 9 years ago

AMIS is very slow when going to a SMIL ID

Reported by: marisa-demeglio Owned by: marisa-demeglio
Priority: critical Milestone: Release Candidate 1
Keywords: ambulant Cc:
Blocked By: Blocking:
Time planned: 1d Time remaining: 1d
Time spent: 1d Estimated Number of Hours:
Add Hours to Ticket: Billable?:
Total Hours:

Description (last modified by marisa-demeglio) (diff)

  1. Download readhowyouwant's Alice in Wonderland book
  2. Click a section or choose a link (far down = slower)
  3. Watch it hang

The problem is that ambulant's goto_node function is very slow when dealing with large numbers of nodes. Currently investigating this.

Change History

comment:1 Changed 9 years ago by marisa-demeglio

  • Priority changed from major to critical

comment:1 Changed 9 years ago by marisa-demeglio

it's actually not hanging -- just incredibly slow.

comment:1 Changed 9 years ago by marisa-demeglio

  • Description modified (diff)
  • Summary changed from AMIS hangs when going to a SMIL ID to AMIS is very slow when going to a SMIL ID

comment:1 Changed 9 years ago by marisa-demeglio

Summarized problem and sent Ambulant log output and book to Jack, along with some notes about where in the Ambulant code seems to be taking so many cycles.

comment:1 Changed 9 years ago by marisa-demeglio

  • Status changed from new to assigned

There is a chance that we can make small improvements here and there, but there is also a chance that this will be a problem that ends up in our "Known Limitations" list.

comment:1 Changed 9 years ago by marisa-demeglio

  • Status changed from assigned to closed
  • Resolution set to wontfix
Note: See TracTickets for help on using tickets.