Ticket #154 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

deleting custom entry from Metadata list twice crash

Reported by: test_team_in Owned by: avneesh-singh
Priority: major Milestone: Obi RC1
Component: Application Version:
Keywords: Cc:
Blocked By: Blocking:
Time planned: 1d Time remaining: 1d
Time spent: 1d Estimated Number of Hours:
Add Hours to Ticket: Billable?:
Total Hours:

Description

Steps:

  1. Open a project and move to custom meta data entry of list in metadata view.
  2. without changing name of entry fill the value and press update button.
  3. Now, move to list and delete the custom entry.
  4. Press delete key on custom entry again.

result: Crash

Change History

comment:1 Changed 11 years ago by julien-quint

  • Owner changed from somebody to julien-quint

The problem is simply that after the entry is deleted, it is still selected, so it can be deleted twice (which causes the crash.)

comment:1 Changed 11 years ago by julien-quint

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in r2033.

comment:1 Changed 11 years ago by test_team_in

  • Status changed from closed to reopened
  • Resolution fixed deleted

It is still crashing because, it is trying to delete metadata entry which is not in the metadata list of presentation.

comment:1 Changed 11 years ago by test_team_in

  • Owner changed from julien-quint to avneesh-singh
  • Status changed from reopened to new

comment:1 Changed 11 years ago by julien-quint

  • Status changed from new to closed
  • Resolution set to invalid

comment:1 Changed 11 years ago by julien-quint

  • Status changed from closed to reopened
  • Resolution invalid deleted

comment:2 Changed 11 years ago by julien-quint

  • Status changed from reopened to closed
  • Resolution set to fixed

(In [2087]) Fixes #154 (deleting custom entry from Metadata list twice crash) (for real this time?)

Note: See TracTickets for help on using tickets.