Ticket #345 (closed defect: wontfix)

Opened 11 years ago

Last modified 2 years ago

pipeline jobs fail if path contain non western characters

Reported by: avneesh-singh Owned by: avneesh-singh
Priority: major Milestone: Obi 4.0 alpha
Component: Application Version:
Keywords: Cc:
Blocked By: Blocking:
Time planned: 1d Time remaining: 1d
Time spent: 1d Estimated Number of Hours: 0.0
Add Hours to Ticket: 0 Billable?: yes
Total Hours:

Description

If the path parameters to pipeline transformers contains non western characters e.g. chinese or hindi characters, pipeline job fails. Workaround: Place all the directories and files to be used by pipeline-lite in a place where there are no non western characters in paths.

Change History

comment:1 Changed 9 years ago by avneesh-singh

  • Add Hours to Ticket set to 0
  • Estimated Number of Hours set to 0.0
  • Milestone changed from Obi 1.2 RC to Obi 1.2
  • Billable? set

comment:2 Changed 9 years ago by avneesh-singh

The issue is related to limitation in library of pipeline lite due to which it cannot accept path in non western characters.
A work around is to copy the complete exported book to another folder where there ar no such characters but it give rise to a huge performance penalty.
So, it will be fixed whenever the library will be updated.

comment:3 Changed 9 years ago by avneesh-singh

  • Milestone changed from Obi 1.2 to post Obi 1.2

comment:4 Changed 7 years ago by avneesh-singh

  • Milestone changed from Obi 2.5 alpha to Obi 2.5 Beta

comment:5 Changed 6 years ago by avneesh-singh

  • Milestone changed from Obi 3.0 to Post Obi 3.0

comment:6 Changed 2 years ago by avneesh-singh

  • Status changed from new to closed
  • Resolution set to wontfix

The issue is in Pipeline-lite, which is not developed further. So, it could not be fixed in current integration with Pipeline-lite. If users on native language Windows OS face this issue, then then can create export directory with English name and place it in the root.

Note: See TracTickets for help on using tickets.